1.4.1 (2016-07-05)

1.4.0 (2016-06-05)

Features

1.3.2 (2015-12-12)

Bug Fixes

1.3.1 (2015-11-12)

Bug Fixes

1.3.0 (2015-11-07)

Features

1.2.0 (2015-11-03)

Features

1.1.0 (2015-09-14)

Bug Fixes

Features

1.0.2 (2015-08-25)

1.0.1 (2015-07-11)

1.0.0 (2015-06-24)

Features

0.11.0 (2015-04-18)

Features

0.10.2 (2015-02-16)

0.10.1 (2014-11-12)

0.10.0 (2014-11-11)

Features

0.9.0 (2014-09-02)

Features

Breaking Changes

If you are customizing renderers by options.renderers, you may have to migrate.

To migrate, change your code from the following:

[
    'file',
    'assertion',
    'diagram',
    'binary-expression'
]

To:

 [
    './built-in/file',
    './built-in/assertion',
    './built-in/diagram',
    './built-in/binary-expression'
 ]

(265d3539), (acf85109)

0.8.0 (2014-08-12)

Features

Breaking Changes

If you already customize formatter config using stringifyDepth, you need to migarte. To migrate, change your code from the following:

var createFormatter = require('power-assert-formatter');
var options = {
    stringifyDepth: 2
};
var formatter = createFormatter(options);

To:

var createFormatter = require('power-assert-formatter');
var options = {
    maxDepth: 1
};
var formatter = createFormatter(options);

Beware that stringifyDepth - 1 === maxDepth !